Delay in transfers
Incident Report for TransferWise
Resolved
Technical glitch was fixed at 5:13 pm (UTC) and transfer flow is back to normal.
Posted Dec 04, 2019 - 17:33 GMT
Identified
We’re aware of a technical glitch delaying transfers. Our team is already working on a fix – in the meantime, transfers are still being processed but running slower than usual.
Posted Dec 04, 2019 - 16:19 GMT