Funding via bank transfers in GBP
Incident Report for Wise
Resolved
This incident has been resolved.
Posted Apr 07, 2020 - 15:34 BST
Investigating
We are experiencing difficulties with receiving bank transfers in GBP at the moment, and this can affect some of your transfers. All other payment methods are working normally. Our team is already working to fix this and we'll keep you posted with any developments.
Posted Apr 06, 2020 - 19:15 BST
This incident affected: Web App (Sending Money, Borderless Account) and Android App, iOS App.